phpBB-Arcade Update auf 3.0.0 (non public)

Mit dem gestrigen Update der phpBB-Arcade von KillBill auf die Hauptversion 3.0.0 sind die Releases Arcade 3.0RC1 bis 3.0RC4 veraltet.  Neben einigen Bugfixes sind in der Entwicklung bis zu diesem “major release” seit der Veröffentlichung der Version 2.0.0 vor wenigen Monaten etliche Funktionen dazu gekommen, einige Veränderungen und Korrekturen haben stattgefunden. Den kompletten Changelog findet ihr im Installationspaket (Mod-Historie in der install.xml/update.xml) oder bei KillBill im Forum. Erstaunlich, mit welcher Energie diese MOD von Woche zu Woche weiterentwickelt wird.

Hier jetzt nur mal ein paar Ausschnitte zu den Funktionserweiterungen zwischen 2.0 und 3.0: „phpBB-Arcade Update auf 3.0.0 (non public)“ weiterlesen

phpBB-Arcade veröffentlicht Version 3.0RC4

Am 27.02.2014 wurde für die Boardunterstützer ein weiterer neuer Releasekandidat der phpBB-Arcade von KillBill freigegeben. Dies ist nun 3.0RC4 (lizenzierte Version, kein öffentlicher Download). Öffentlich ist diese Version erst in einem Jahr verfügbar, wie in einem meiner vorigen Beiträge bereits erwähnt. Diese Version ist durch einen domainabhängigen  Aktivierungsschlüssel gesichert, der nicht übertragbar ist. „phpBB-Arcade veröffentlicht Version 3.0RC4“ weiterlesen

Telegram statt WhatsApp

Nachdem wir alle erfreut wurden durch die Nachricht, dass Facebook nun auch noch den letzten Kontakt bei uns abgreift, der noch nicht mit Facebook verbunden ist, indem es schlicht unsere WhatsApp-Kommunikation aufgekauft hat, wurde schon viel über Alternativen gemeldet. Und die sind allmählich auch erforderlich. Und zwar nach Möglichkeit eine Alternative, die weder Google, noch Facebook gehört. So allmählich gehts über die Hutschnur. Was hat Facebook nun auch noch in der letzten privaten Nachricht verloren? Und gut – WhatsApp war nie besonders sicher, aber das setzt für mich dem Ganzen nun die Krone auf. „Telegram statt WhatsApp“ weiterlesen

Neues von phpBB-Arcade – Version 3.x

Gleich mit der Veröffentlichung von phpBB-Arcade 2.0.0 als aktuell letztes offizielles Release, welches auch auf phpBB.com zur Validierung eingereicht wurde, hat KillBill angefangen, die Versionen ab 3.x zu entwickeln.

Diese haben allerdings auch eine Verfahrensänderung mit sich gebracht. Konnte man bis Version 2.0RC7 noch anonym auf dem Arcade Support Board herumstromern, und die Versionen herunterladen, ist nun mit der Freigabe von Version 2.0.0 für Support eine Registrierung auf http://phpbbarcade.jatek-vilag.com erforderlich. Gefordert wird die gültige Webseitenadresse, auf der phpBB-Arcade laufen soll, und der reale Name zusätzlich zum Nickname. Angefragt wird außerdem der Facebook Account, der aber nicht zwingend ist.

Hintergrund ist, „Neues von phpBB-Arcade – Version 3.x“ weiterlesen

Übersetzung: phpRivals Mod 2.0.1deutsch für phpBB

Eine weitere Auftragsarbeit, die ich auf Wunsch angefangen habe. Eine deutsche Übersetzung für phpRivals Mod.

MOD-Übersetzer: ScaniaLady
MOD-Name: phpRivals MOD
MOD-Autor: soshen
MOD-Version: 2.0.1 beta
MOD-Sprachen original: it, pt, en, fr
MOD-Download: Download bei nipponart.org
MOD-Demolink: Demo
MOD-Beschreibung: Originalbeschreibung
Es handelt sich um ein Clan-Turnier- und Verwaltungsprogramm für phpBB
Sprachdatei(en): deutsch (erste Alpha-version, Fehler bitte melden)

phpRivals_2-0-1_lang_de_alpha_v1

zusätzliche Anweisungen:

„Übersetzung: phpRivals Mod 2.0.1deutsch für phpBB“ weiterlesen

Warnung vor Schadcode in Flashgame-Ordnern

Vor kurzem entdeckte ich in der Foreninstallation eines Freundes Schadcode im gamedata-Ordner seiner Arcade.
Diese Spiele stammten NICHT von origon.dk, sondern von einer anderen Spielhalle, die Spiele zum massenhaften Download anbietet.

In den gamedata-Ordnern befanden sich php Dateien und .htaccess Dateien, was an sich und ohnehin schon suspekt ist. Bei näherer Betrachtung im Editor stellte ich fest, dass diese Dateien base64 Schadcode enthielten. Es handelt sich um einen Trojaner, der scheinbar eine Backdoor installiert, die Serverdaten sammelt und von einer anderen Seite vermutlich weitere Codes nachlädt, um den Server zu infizieren.

„Warnung vor Schadcode in Flashgame-Ordnern“ weiterlesen

Übersetzung: Deutsche Sprachdateien für Zodiac Signs 1.0.2

Es wurde eine deutsche Übersetzung gewünscht für die MOD Zodiac Signs 1.0.2

Hier ist meine Version.

MOD-Übersetzer: ScaniaLady
MOD-Name:  Zodiac Signs
MOD-Autor: Galandas
MOD-Version: 1.0.2
MOD-Sprachen mitgeliefert: it, en
MOD-Beschreibung: Mit dieser Mod können Tierkreiszeichen in Beiträgen und im Profil hinzugefügt werden. Über ACP können Bilder für Tierkreiszeichen hinzugefügt, bearbeitet und gelöscht werden.
Siehe Thema auf phpBB.com in der Mod-Datenbank und unter Customise.
MOD-Download:  phpbb.com
MOD-Demolink:  Altervista
Sprachdatei(en): deutsch “du” – [de] Sprachpaket
zusätzliche Anweisungen:
Dies ist nur das deutsche Sprachpaket für o.g. Modifikation.
Zodiac Signs 1.0.2 muss zuerst bzw. gleichzeitig installiert werden, um das Sprachpaket zu nutzen.

Zusätzlich muss noch ein Eintrag in der bereits vorhandenen language/de/common.php vorgenommen werden:

„Übersetzung: Deutsche Sprachdateien für Zodiac Signs 1.0.2“ weiterlesen

Übersetzung: Deutsche Sprachdateien für Safe Gamer Tag 2.3.4

Als Auftragsarbeit auf http://allround-phpbb.de wurde eine deutsche Übersetzung für Safe Gamertag 2.3.4 gewünscht. Die MOD liefert italienisch und englisch mit. Hier ist meine Version für die deutsche Übersetzung.

MOD-Übersetzer: Lady (Scanialady)
Sprachdatei(en): deutsch
MOD-Name: Safe Gamertag (gesonderte Installation zusätzlich erforderlich!)
MOD-Version: 2.3.4
MOD-Autor: Soshen
MOD-Download und Support: phpbb.com oder Homepage des Autors
MOD-Beschreibung: Forennutzer können im Persönlichen Bereich ihre Spielernamen/Gamertags einstellen für

„Übersetzung: Deutsche Sprachdateien für Safe Gamer Tag 2.3.4“ weiterlesen

phpBB-Arcade ab 2.0RC6 ohne subsilver2-Support

Es gibt eine Ankündigung auf phpbbarcade.jate-vilag.com, dass nur noch einer der beiden Grundstyles von phpBB supportet wird.

KillBill hat sich nun dem allgemeinen Trend angeschlossen, subsilver2-Styles nicht mehr weiter zu unterstützen.

Das ist sicher bedauerlich für jeden, der noch diese Styles benutzt. Andererseits ist es aber eine logische Folge der schon alten Ankündigung des phpBB-Teams, dass ab dem nächsten großen Release subsilver2 nicht mehr unterstützt oder mitgeliefert werden wird. Insofern ist damit zu rechnen gewesen, dass auch phpBB-Arcade ohne subsilver2 auskommen muss – jetzt oder in der Zukunft.

Wer noch subsilver2-Styles benutzt, sollte sich also allmählich davon trennen, oder er muss auf weitere Updates verzichten bzw. die Styles selber coden. Alle kommenden phpBB-Arcade Updates werden nur noch mit prosilver Templates ausgeliefert.

Allerdings gibt es den Gedanken, eventuell an einem mobile-Design zu feilen. Möglicherweise wird es mal ein Template für Artodia Mobile Style geben.

Ständige Abstürze des Adobe Flash Player Plugins

derzeit häufen sich wieder Berichte über Abstürze des Adobe Flash Plugins unter Firefox.

Die aktuelle Flash Version ist 11.5 – doch seit 11.3 treten diese Abstürze immer wieder mal nach einem Update auf, abhängig vom verwendeten System des Benutzers. Flash Player 11.5.r502 scheint auch einer dieser Kandidaten zu sein.

Immerhin ist die Ursache des Fehlers nun ausgemacht: es ist eine neue Funktion, die mit 11.3 erschienen ist, nämlich der sogenannte “protected mode”, der dafür sorgen soll, dass Flashanwendungen nicht mit bösartigem Code auf das Nutzersystem zugreifen können.

In erster Linie sorgt es aber offensichtlich vor allem bei Benutzern älterer Betriebssysteme dafür, dass der Benutzer nicht auf Flash zugreifen kann. Das ist nicht im Sinne des Erfinders. Mittlerweile sind auch die Systemanforderungen für dieses Plugin gewaltig – unter 2.6Ghz braucht man das eigentlich nicht zu installieren, und es wird Windows Vista vorausgesetzt. Wie verträgt sich das mit dem “du musst ständig updaten, damit eine veraltete Version keine Gefahr für deinen Rechner ist”? Meiner Ansicht nach gar nicht, weil wenn es schon mit Zwangsupdates „Ständige Abstürze des Adobe Flash Player Plugins“ weiterlesen